Login | Register
My pages Projects Community openCollabNet

Discussions > issues > [maxq-issues] [Issue 38] New - ./bin/maxq lanch throws execption during tests [linux debian]

maxq
Discussion topic

Hide all messages in topic

All messages in topic

[maxq-issues] [Issue 38] New - ./bin/maxq lanch throws execption during tests [linux debian]

Author chrismann
Full name Christopher Mann
Date 2004-09-06 07:44:46 PDT
Message http://maxq.tigris.o​rg/issues/show_bug.c​gi?id=38
                  Issue #:|38
                  Summary:|./bin/maxq lanch throws execption during tests [linux
                          |debian]
                Component:|maxq
                  Version:|current
                 Platform:|PC
               OS/Version:|Linux
                      URL:|
                   Status:|NEW
        Status whiteboard:|
                 Keywords:|
               Resolution:|
               Issue type:|DEFECT
                 Priority:|P3
             Subcomponent:|www
              Assigned to:|issues@maxq
              Reported by:|chrismann






------- Additional comments from chrismann at tigris dot org Mon Sep 6 07:44:46 -0700 2004 -------
My problems when lauching Maxq are as folows :

# ./bin/maxq
Exception in thread "main" java.lang.NullPointerException
        at com.bitmechanic.maxq​.Main.runTests(Main.​java:141)
        at com.bitmechanic.maxq​.Main.main(Main.java​:101)
# java -version
java version "1.4.2_02"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_02-b03)
Java HotSpot(TM) Client VM (build 1.4.2_02-b03, mixed mode)
# ./bin/maxq -r
org.apache.commons.c​li.MissingArgumentEx​ception: no argument for:r
        at org.apache.commons.c​li.Parser.processArg​s(Parser.java:239)
        at org.apache.commons.c​li.Parser.processOpt​ion(Parser.java:277)​
        at org.apache.commons.c​li.Parser.parse(Pars​er.java:170)
        at org.apache.commons.c​li.Parser.parse(Pars​er.java:114)
        at com.bitmechanic.maxq​.Main.parseLine(Main​.java:38)
        at com.bitmechanic.maxq​.Main.main(Main.java​:93)
Exception in thread "main" java.lang.NullPointerException
        at com.bitmechanic.maxq​.Main.runTests(Main.​java:141)
        at com.bitmechanic.maxq​.Main.main(Main.java​:101)


I am on a Linux Debian Sarge with the standard packages installed. Java may be
(probably is) from Sun.

Ant compile worked just fine.

Do you know where this is coming from and how I may get maxq to work ?

Chris
Messages per page: