Login | Register
My pages Projects Community openCollabNet

Discussions > dev > [maxq-dev] Re: [clif] HTTPCapture & SSL

maxq
Discussion topic

Back to topic list

[maxq-dev] Re: [clif] HTTPCapture & SSL

Author dillense
Full name Bruno Dillenseger
Date 2011-01-06 08:29:08 PST
Message 06/01/2011 15:46, Marc Delerue wrote:
> Hello,
>
> I'm trying to set up a test plan on a website. Using the HTTPSimple
> example from the quickstart manual, I can get HTTPS pages but using
> HTTPCapture with the proxy and my browser I always get a blank page.
>
> I modified the clif.props file to set the trusStore pass and password,
> but there is no changes.
>
> Does anybody know how I can correctly set my project to make it working ?
>
> Thank you in advance
>
> Regards
>
> Marc
Hello Marc,

You can do HTTPS testing with CLIF's HttpInjector, but the embedded
capture tool based on Maxq project (from tigris.org) does not work with
HTTPS URIs.

FYI, we already had discussions about this issue on maxq's mailing list,
but we did not find an agreement on the solution.
I proposed a classical solution that consists in having maxq
automatically change some URIs from HTTPS to HTTP so that the browser
uses HTTP with the capture proxy, while the capture proxy uses - and
records - the right HTTPS URIs.

For the time being, the only solution is to manually enter HTTPS URIs in
the scenario (using the ISAC scenario editor). As a workaround, maybe
you can use another HTTP capture tool supporting HTTPS that will give
you the right URLs that you can copy/paste in the scenario.

Best regards,
-- Bruno.

« Previous message in topic | 1 of 1 | Next message in topic »

Messages

Show all messages in topic

[maxq-dev] Re: [clif] HTTPCapture & SSL dillense Bruno Dillenseger 2011-01-06 08:29:08 PST
Messages per page: