Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: [maxq-users] Getting a SyntaxError when trying to run a recorded script

maxq
Discussion topic

Back to topic list

Re: [maxq-users] Getting a SyntaxError when trying to run a recorded script

Author oliverbock
Full name Oliver Bock
Date 2008-01-13 00:45:36 PST
Message Python (and Jython) care about indenting. It must be completely
consistent except on comment lines and blank lines. Python/Jython
consider a tab character to be equivalent to 8 spaces I think, but it
is best to have no tabs.

Did you edit the script using another editor? It might have replaced
tabs with spaces or spaces with tabs, or somehow mucked up the
indent. Does the indenting look consistent in Notepad?


   Oliver

--
On 11/01/2008, at 10:39, Dan Cordell (Temporary) wrote:

> I'm running MaxQ on two different machines, WinXP and Vista, and
> getting an identical error when I try to run a recording. Here's
> the error, before I explain what I was doing:
>
> --------------------​--------------------​--------
> Traceback (innermost last):
> (no code object) at line 0
> File "<string>", line 15
> self.setCharset(';
> boundary=-----------​----------------2795​8115224164')
> ^
> SyntaxError: inconsistent dedent
> --------------------​--------------------​--------
> All I've done so far is install Jython, MaxQ, and then recorded a
> short script (logging into an internal site, clicking one link,
> then logging out). I've done the recording seperately on each
> machine. As I said above, one machine is running WinXP (all the
> latest service packs and patches), and the other is running Vista
> (likewise).
>
> Java version is 1.6.0_03 on each machine.
>
> I did a search through the issues and user archives of the MaxQ
> mailing list, as well as several web searches, and as far as I can
> tell nobody else has had this problem.
>
> Anyone have any ideas? Have I missed a step in installation, or
> misconfigured MaxQ (not that I saw any configuration to deal with
> upon installation)?
>
> Thanks!
>
Attachments

« Previous message in topic | 2 of 4 | Next message in topic »

Messages

Show all messages in topic

Getting a SyntaxError when trying to run a recorded script "Dan Cordell (Temporary)" <DanCo at vulcan dot com> "Dan Cordell (Temporary)" <DanCo at vulcan dot com> 2008-01-10 15:39:26 PST
     Re: [maxq-users] Getting a SyntaxError when trying to run a recorded script oliverbock Oliver Bock 2008-01-13 00:45:36 PST
         Re: [maxq-users] Getting a SyntaxError when trying to run a recorded script Carphill <c_phillips_2000 at yahoo dot co dot uk> Carphill <c_phillips_2000 at yahoo dot co dot uk> 2008-10-07 05:09:44 PDT
             Re: [maxq-users] Getting a SyntaxError when trying to run a recorded script oliverbock Oliver Bock 2008-10-08 22:20:58 PDT
Messages per page: