Login | Register
My pages Projects Community openCollabNet

Discussions > users > [maxq-users] WinXP SP2 Post problem

Discussion topic

Back to topic list

[maxq-users] WinXP SP2 Post problem

Author fcohen
Full name Frank Cohen
Date 2004-10-14 21:48:31 PDT
Message Using MaxQ 97 and IE 6 on WinXP SP2:

1) Launch MaxQ
2) Launch IE
3) IE - Internet Tools -> Connections -> use localhost on port 8090
4) MaxQ -> File -> New -> Standard Script
5) MaxQ -> Test -> Start Recording, I see the following in the MaxQ

# Generated by MaxQ [com.bitmechanic.max​q.generator.JythonCo​deGenerator]
from PyHttpTestCase import PyHttpTestCase
from com.bitmechanic.maxq import Config
global validatorPkg
if __name__ == 'main':
     validatorPkg = Config.getValidatorPkgName()
# Determine the validator for this testcase.
exec 'from '+validatorPkg+' import Validator'

# definition of test class
class wierd(PyHttpTestCase):
     def runTest(self):
         self.msg('Test started')

     # ^^^ Insert new recordings here. (Do not remove this line.)

# Code to load and run the test
if __name__ == 'main':
     test = wierd("wierd")

6) IE -> http://examples.push​totest.com/responder​/htmlresponder, IE
shows the correct page, no change to the MaxQ window
7) IE ->
IE shows the correct page, again no change to the MaxQ window
8) Click the Transfer Funds submit button. No activity. Browser
eventually times-out after 60+ seconds.

If I tell IE not to use the MaxQ proxy then the Transfer Funds submit
works fine.

When I run the same from my Mac OS X machine using MaxQ 97 and Safari
this works. MaxQ records the script and the browser returns the correct
response to the Transfer Funds submit.


Frank Cohen, PushToTest, http://www.PushToTest.com, phone: 408 374 7426
Author of "Java Testing and Design: From Unit Tests to Automated Web
from Prentice Hall, details at http://thebook.pushtotest.com

To unsubscribe, e-mail: users-unsubscribe@ma​xq.tigris.org
For additional commands, e-mail: users-help at maxq dot tigris dot org

« Previous message in topic | 1 of 4 | Next message in topic »


Show all messages in topic

[maxq-users] WinXP SP2 Post problem fcohen Frank Cohen 2004-10-14 21:48:31 PDT
     Re: [maxq-users] WinXP SP2 Post problem oliverbock Oliver Bock 2004-10-14 22:47:47 PDT
     Re: [maxq-users] WinXP SP2 Post problem oliverbock Oliver Bock 2004-10-15 02:05:47 PDT
         Re: [maxq-users] WinXP SP2 Post problem fcohen Frank Cohen 2004-10-15 08:33:12 PDT
Messages per page: