Login | Register
My pages Projects Community openCollabNet

Discussions > users > [maxq-users] upload error

maxq
Discussion topic

Back to topic list

[maxq-users] upload error

Author petersm <petersm at venzia dot com>
Full name petersm <petersm at venzia dot com>
Date 2004-04-12 07:41:49 PDT
Message Hello all,

I was using MaxQ to test the upload of an image to a given site (mainly just
to play around with it and see the code generated) and it seems that the
generated python code has some problems. Everything goes fine when recording,
but when trying to play the test back I get this error....

Traceback (innermost last):
  (no code object) at line 0
SyntaxError: ('Lexical error at line 39, column 658. Encountered: "\\r" (13),
after : ""', ('<string>', 39, 658, u'
\'\uFFFD1\uFFFDF​uFFFDH\uFFFD6\uFF​FD}1\uFFFDp\x1D2HL​,\uFFFD\x14sL=\uF​FFD\x07:?/`H\uFFFD​\uFFFDcW\uFFFD\uF​FFDn\uFFFDa\uFFFD​x0E\uFFFD<O​&Nx\uFFFD\x1E\uFF​FD\uFFFD\uFFFD\x1​7\uFFFD\x07\uFFFD​a\x01l\uFFFD\x06~​\uFFFD\x0B\uFFFD​uFFFD\uFFFD}\x15​uFFFD\uFFFDw\uFFF​D;\uFFFDO~K8~\uFFF​D\uFFFD\uFFFD\uFF​FD\uFFFD\uFFFD\x1​5k\uFFFD\\\x7F\​uFFFD=V\x07\x0F\u​FFFD\uFFFD^fW\uFFF​D\uFFFD\uFFFD5\uF​FFD\uFFFD\uFFFD\u​FFFD\uFFFD\uFFFD~​uFFFD~\uFFFD\uFFF​D\uFFFD\f\uFFFD\​uFFFD9\uFFFDFK\x01​
\x06\uFFFD\x0F?\​uFFFD\uFFFD\uFFFD​uFFFD\uFFFD\uFFFD​\uFFFD\x05\uFFFD?​\x13X\uFFFDka\uFF​FD\\\'<\uFFFD​fx\uFFFDF-E<y\x​7F\x05\uFFFD\x1D​t\uFFFD6\uFFFDj\​uFFFDo3%\x16\uFFFD​}\x19\uFFFDY\uFFF​D1\uFFFD\uFFFD!o;​uFFFD\uFFFD7\uFFF​D*\uFFFDm>K\uFF​FDM\uFFFD\uFFFDY\​x0B2\uFFFD\uFFFD]​uFFFD4v\uFFFDT\uF​FFD\uFFFD+\uFFFD\​uFFFDY|\uFFFD\uFFF​D\uFFFDtXF\uFFFD\​uFFFD\x1C\x12:.W\​uFFFD\x10\uFFFD\u​FFFD\x02"
\b\uFFFD\uFFFD""​x00\uFFFD\uFFFD\​x02"\uFFFD\x0E{Z\​\\x1A\t\uFFFD\​\'\uFFFD\x03\uF​FFD$P\uFFFD9p\uFF​FD\uFFFDykK\uFFFD​x03\uFFFD\uFFFD^​uFFFD\uFFFDJX\uFF​FD
\uFFFD\uFFFDX\uFF​FDn\x1D\x18o\uFFF​D*\uFFFD\x15\uFFF​D\uFFFD\uFFFD\uFF​FD\uFFFDT\uFFFD\u​FFFD\uFFFDX$\uFFF​D\x07\uFFFD\x0Fs​uFFFD\x0Bdh\uFFFD​)I+\uFFFD\uFFFD\u​FFFD8j\uFFFDt&​uFFFDk\b\uFFFD\u​FFFD\uFFFD\uFFFD\​uFFFD\uFFFD\x028\​uFFFD\uFFFD\uFFFDI​N\x1BQW\uFFFDX\uF​FFD\x04\uFFFD\uFF​FD\x129\uFFFD-\uF​FFD#\uFFFD\uFFFDe​uFFFD\uFFFD\uFFFD​\uFFFD\uFFFD108\u​FFFD\uFFFDq\uFFFD​uFFFDR\uFFFD6\uFF​FD\uFFFD\uFFFD\x1​8\uFFFD\uFFFD\uFF​FD$V\uFFFDC\uFFFD​2x\x1DGU\uFFFD\uF​FFDkn\uFFFD\uFFFD​uFFFDB_\uFFFD\uFF​FD\uFFFD\uFFFD\uF​FFD\\zDrC\uFFFD6F​I\x13\uFFFD{\uFFF​D+\uFFFD0p8]\uFFFD​\uFFFD\uFFFD\uFFF​DWM\uFFFD\uFFFD\u​FFFD\x11\x07\uFFF​D\x1D\uFFFD\uFFFD​~\uFFFDnT\uFFFDv\​uFFFD\x03\uFFFDk\​uFFFD\uFFFDs\uFFFD​f\x0B\uFFFD\uFFFD​\uFFFD\uFFFD\uFFF​D~\uFFFD\uFFFDZ\u​FFFD\uFFFD3\x04u%​uFFFDF\x16\uFFFD#​\uFFFDw\x03\uFFFD​\uFFFDF\uFFFD\x1D​\uFFFD.C\uFFFDi\u​FFFDG|mOS\uFFFD\uF​FFD^\x1E*\uFFFDC\​uFFFD?\x1E4s4{\uFF​FD!hi\uFFFDe\uFFFD​\uFFFDz\uFFFDq\uF​FFD\x0F\uFFFDn\\​N\x1A\x00\x1C\uF​FFD\uFFFDZ4\uFFFD​uFFFDu\uFFFD,hL;\​uFFFDp\uFFFD\uFFFD​\uFFFDzu?\uFFF
 D^\uFFFD\uFFFD\uF​FFD+\x05$\x11\uF​FFD\t\uFFFD\uFFFD​\uFFFD\uFFFDc\uFF​FD\uFFFD}B\uFFFD-N​H\uFFFDCkR\uFFFD\​uFFFDM<5\uFFFD\​uFFFD\uFFFDQ\uFFFD​k\uFFFDF\uFFFD\uF​FFDN\uFFFD[\uFFFD​uFFFDn\x19\uFFFD​uFFFD\x00\uFFFDlQ​\uFFFDg\uFFFD\uFF​FDD\uFFFD\uFFFD\x​0B\uFFFDW\uFFFDc\​uFFFD;\uFFFD\uFFFD​UFV\uFFFD\uFFFD\u​FFFD\uFFFD:s_\uFFF​D\uFFFD'))

    at org.python.core.pars​er.fixParseError(par​ser.java)
    at org.python.core.pars​er.parse(parser.java​)
    at org.python.core.Py.c​ompile_flags(Py.java​)
    at org.python.core.Py.c​ompile_flags(Py.java​)
    at org.python.util.Pyth​onInterpreter.exec(P​ythonInterpreter.jav​a)
    at com.bitmechanic.maxq​.RunTestDialog.run(R​unTestDialog.java:95​)
    at java.lang.Thread.run(Unknown Source)


Here is the generated python code.

# imports
from com.bitmechanic.maxq import HttpTestCase, EditorPane
from junit.textui import TestRunner
from java.lang import *
from java.io import *
from java.util import *
from HTTPClient import NVPair


# definition of test class
class MaxQTest(HttpTestCase):
    def __init__(self):
        HttpTestCase.__init__(self, "")

    def runTest(self):
        data = '-------------------​----------1714636915​1957747793424238335​r\n'\
        'Content-Disposition: form-data; name="ImageGalleryMa​nager_mode"\r\n'\​
        '\r\n'\
        'insertImage\r\n'\
        '-------------------​----------1714636915​1957747793424238335​r\n'\
        'Content-Disposition: form-data; name="*main"\r\n'\
        '\r\n'\
        'ImageGalleryManager\r\n'\
        '-------------------​----------1714636915​1957747793424238335​r\n'\
        'Content-Disposition: form-data;
name="ImageGalleryMa​nager_Gallery_id"\r​\n'\
        '\r\n'\
        '1\r\n'\
        '-------------------​----------1714636915​1957747793424238335​r\n'\
        'Content-Disposition: form-data; name="template"\r\n'\
        '\r\n'\
        'topaz.html\r\n'\
        '-------------------​----------1714636915​1957747793424238335​r\n'\
        'Content-Disposition: form-data;
name="ImageGalleryMa​nager_Image_Name"; filename="1.jpg"\r\n'\
        'Content-Type: image/jpeg\r\n'\
        '\r\n'\
        '&#65533;&#6​5533;&#65533;​&#65533;
Attachments

« Previous message in topic | 1 of 1 | Next message in topic »

Messages

Show all messages in topic

[maxq-users] upload error petersm <petersm at venzia dot com> petersm <petersm at venzia dot com> 2004-04-12 07:41:49 PDT
Messages per page: